Информатика, вопрос задал mari1147 , 8 лет назад

"массив в состоит из 15 элементов заполненными от 0 до 50 радномно, вычислите количество четных элементов"
Напишите программу Паскаля

Ответы на вопрос

Ответил M12003
0
var a: array [1..15] of integer; 
  i,n:integer;
begin
for i:=1 to 15 do begin 
    a[i]:=random(50); 
    if (a[i] mod 2)=0 then    
        n:=n+1;
end;
writeln(a);
writeln;
writeln(n);
end.
Ответил mari1147
0
спасибо большое <3
Ответил shakira3421
0
Uses crt;
Var a:array [1..15] of integer;
i,k:integer;
begin
for i:=1 to 15 do
begin
a[i]:=random(50)-20;
write (a[i]:4);
k:=0;
end;
writeln;
for i:=1 to 15 do
if a[i]>0 then
begin
k:=k+1;
end;
writeln ('колво элементов',k);
end.



Ответил shakira3421
0
Это положительные элементы
Новые вопросы