Массив содержит значения отметок 22 учащихся класса за контрольную работу (случайные числа от 2 до 10).После работы надо ошибками учащиеся переписали работу и получили отметки на балл выше (кроме тех ,кто получил 10).Составьте программу ,которая выводит отметки ,полученные учениками первоначально и после работы надо ошибками . Pascal
Ответы на вопрос
Ответил Maxuch
0
const n = 22;
var A: array[1..n] of integer;
begin
write('До переписывания:');
for var i:= 1 to n do begin
A[i] := 2 + random(9);
write(' ', A[i]);
end;
writeln;
write('После переписывания:');
for var i:= 1 to n do begin
if (A[i] <> 10) then
A[i] := A[i] + 1;
write(' ', A[i]);
end;
end.
Новые вопросы