Информатика, вопрос задал debil2shishlja , 2 года назад

Массив содержит результаты соревнований по прыжкам в длину в сантиметрах (случайные числа в диапазоне от 280 до 370). Количество спортсменов вводится с клавиатуры. Составьте программу, определяющую номер и результат победителя
Язык программирования - паскаль абц.


uplmtq: Какой ЯП?
debil2shishlja: паскаль

Ответы на вопрос

Ответил uplmtq
6

Ответ:

begin

 var size := readinteger();

 var mas := ArrRandomInteger(size, 280, 370);

 mas.Println;

 var max := mas[0];

 var ind := 0;

 for var i := 1 to mas.Length - 1 do

 begin

   if (mas[i] > max) then

   begin

     max := mas[i];

     ind := i;

   end;

 end;

 writeln('Номер победителя: ', ind);

 writeln('Результат победителя: ', max);

end.

Объяснение:

begin  // Начало программы

 var size := readinteger();  // Считывание размера массива с клавиатуры

 var mas := ArrRandomInteger(size, 280, 370);  // Объявление массива размером size + заполнение массива случайными значениями из диапазона [280, 370].

 mas.Println;  // Вывод массива

 var max := mas[0];  // Возьмем, что максимальный результат у нулевого индекса массива

 var ind := 0;  // Номер победителя = 0

 for var i := 1 to mas.Length - 1 do  // Идём от единицы до размера массива - 1 (т. к. массив идёт с 0, его мы уже взяли в максимум)

 begin  // Начало цикла

   if (mas[i] > max) then  // Если значения массива с индексом i > значения переменной max

   begin  // Начало условного оператора

     max := mas[i];  // Присваиваем переменной max значение массива с индексом i

     ind := i;  // Присваиваем переменной ind индекс максимального элемента

   end;  // Конец условного оператора

 end;  // Конец цикла

 writeln('Номер победителя: ', ind);  // Выводим ответ

 writeln('Результат победителя: ', max);  // Выводим ответ

end. // Конец программы

Новые вопросы