Массив содержит информацию об отметках по информатике 10 учащихся класса. Отметки водятся с клавиатуры.Составьте программу,которая вычисляет средний балл по предмету и количество учащихся с отметками выше среднего балла.
Ответы на вопрос
Відповідь:
C++ code:
#include <iostream>
void input_list(int *list,const int size){
std::cout << "Enter info" << std::endl;
for(int i = 0; i < size; i++){
std::cout << i + 1 << ": ";
std::cin >> list[i];
}
std::cout << std::endl;
}
void print_list(int *list,const int size){
for(int i = 0; i < size; i++){
std::cout << list[i] << " ";
}
std::cout << std::endl;
}
double average(int *list,const int size){
double av = 0;
for(int i = 0; i < size; i++){
av += list[i];
}
return av / 10;
}
int amount_student(int *list,const int size, double aver){
int counter = 0;
for(int i = 0; i < size; i++){
if(list[i] > aver){
counter++;
}
}
return counter;
}
int main(){
const int size = 10;
int list[size];
input_list(list,size);
print_list(list,size);
double aver = average(list,size);
std::cout << "Average: " << aver << std::endl;
std::cout << "Amount students: " << amount_student(list,size,aver) << std::endl;
return 0;
}