Массив содержит четное количество элементов. напишите программу которая сортирует первую половину массива по возрастанию а вторую по убыванию. Каждый
элемент должен остаться в "своей" половине
C++ пожалуйста
Ответы на вопрос
Ответил irka1804
0
#include <algorithm>
#include <iostream>
#include <vector>
bool ToLess(int a, int b) {
return a > b;
}
int main() {
int count;
std::cin >> count;
std::vector<int> vectorOfNombers(count);
for (size_t i = 0; i != count; ++i) {
std::cin >> vectorOfNombers[i];
}
sort(vectorOfNombers.begin(), vectorOfNombers.begin() + count / 2 - 1); sort(vectorOfNombers.begin() + count / 2, vectorOfNombers.end(), ToLess);
for (size_t i = 0; i != count; ++i) {
std::cout << vectorOfNombers[i] << " ";
}
}
#include <iostream>
#include <vector>
bool ToLess(int a, int b) {
return a > b;
}
int main() {
int count;
std::cin >> count;
std::vector<int> vectorOfNombers(count);
for (size_t i = 0; i != count; ++i) {
std::cin >> vectorOfNombers[i];
}
sort(vectorOfNombers.begin(), vectorOfNombers.begin() + count / 2 - 1); sort(vectorOfNombers.begin() + count / 2, vectorOfNombers.end(), ToLess);
for (size_t i = 0; i != count; ++i) {
std::cout << vectorOfNombers[i] << " ";
}
}
Новые вопросы