Массив из чисел 0-10. Найдите произведение элементов массива с нечетными номерами и найдите наибольший элемент массива (ПАСКАЛЬ)
помогите вообще не понимаю эту тему
Ответы на вопрос
Ответил AnonimusPro
1
const n=8;
var a: array[1..n] of integer;
i,p,m: integer;
begin
write('массив: ');
for i:=1 to n do begin
a[i]:=random(11);
write(a[i],' ');
end;
m:=a[1];
p:=1;
for i:=1 to n do begin
if i mod 2<>0 then p:=p*a[i];
if a[i]>m then m:=a[i];
end;
writeln;
writeln('произведение элементов с нечетными номерами: ',p);
write('наибольший элемент массива: ',m);
end.
Ответил BobbyFresnel
0
===== PascalABC.NET =====
begin
var n := ReadInteger('Число элементов в массиве?');
var a := ArrRandom(n, 0, 10);
a.Println;
var i := 0;
var p: int64 := 1;
while i < n do
begin
p *= a[i];
i += 2
end;
Println('Произведение элементов с нечетными номерами:', p);
Println('Наибольший элемент массива:', a.Max)
end.
Приложения:

Новые вопросы
Українська література,
1 год назад
Физика,
1 год назад