Массив из 10 элементов заполняется целыми числами. Составьте программу, которая вычисляет среднее арифметическое элементов, являющихся двузначными числами. (2 задача)
Приложения:

Ответы на вопрос
Ответил Impersona1
0
program wk;
var mas:array [1..10] of integer;sr,k,i:integer;
begin
k:=0;
sr:=0;
for i:=1 to 10 do
begin
readln(mas[i]);
if (mas[i] div 10)<>0 then
begin
sr:=mas[i]+sr;
k:=k+1
end;
end;
writeln(sr/k)
end.
var mas:array [1..10] of integer;sr,k,i:integer;
begin
k:=0;
sr:=0;
for i:=1 to 10 do
begin
readln(mas[i]);
if (mas[i] div 10)<>0 then
begin
sr:=mas[i]+sr;
k:=k+1
end;
end;
writeln(sr/k)
end.
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Биология,
8 лет назад
Математика,
8 лет назад
Литература,
9 лет назад