Линейный массив содержит сведения о количестве осадков, выпавших за каждый из 12 месяцев одного года. Составить программу, определяющую общее количество осадков за этот год, среднемесячное количество осадков, количество засушливых месяцев (когда количество осадков было меньше 30 мм), самый засушливый месяц года. для Turbo Pascal.
Ответы на вопрос
Ответил Аноним
1
program zadacha;
var
a: array [1..12] of integer;
i, o, k, z, j: integer;
s:real;
begin
writeln('vvedite kolichestvo osadkov');
for I:=1 to 12 do
read(a[I]);
o:=0;
for I:=1 to 12 do
o:=o+a[I];
writeln('obshee kolichestvo osadkov=',o);
s:=o/12;
writeln('srednee kolichestvo=',s:3:2);
k:=0;
for i:=1 to 12 do
if a[I]<30 then k:=k+1;
writeln('kolichestvo zasushlivih=',k);
j:=30;
for I:=1 to 12 do
if a[I] begin
j:=[I];
z:=I;
end;
writeln('samiy zasusliviy mesyac=',z);
readln;
end.
var
a: array [1..12] of integer;
i, o, k, z, j: integer;
s:real;
begin
writeln('vvedite kolichestvo osadkov');
for I:=1 to 12 do
read(a[I]);
o:=0;
for I:=1 to 12 do
o:=o+a[I];
writeln('obshee kolichestvo osadkov=',o);
s:=o/12;
writeln('srednee kolichestvo=',s:3:2);
k:=0;
for i:=1 to 12 do
if a[I]<30 then k:=k+1;
writeln('kolichestvo zasushlivih=',k);
j:=30;
for I:=1 to 12 do
if a[I] begin
j:=[I];
z:=I;
end;
writeln('samiy zasusliviy mesyac=',z);
readln;
end.
Новые вопросы
Русский язык,
2 года назад
Математика,
2 года назад