ЛЁГКАЯ ЗАДАЧА ПО ПАСКАЛЮ! ПОМОГИТЕ, ПОЖАЛУЙСТА!
Составьте программу которая позволяет удалить второе слово строки s. Строку s, состоящую из 2 слов, разделённых пробеламі, введите с клавbатуры.
Ответы на вопрос
Ответил 140201
0
var s: string; x,i: byte;
begin
writeln('Введите строку:');
readln(s);
for i:=2 to length(s) do begin
if s[i]=' '
then begin
x:=i+1;
while (s[x]<>' ') and (x<length(s)) do begin
delete(s,x,1);
end;
delete(s,x,1);
break;
end;
end;
writeln(s);
end.
--------------------------
Пример 1:
мама мыла
мама
Пример 2:
Мама мыла раму
Мама раму
---------------------------
PS: считается, что строка не начинается с пробела и не может быть два пробела подряд
begin
writeln('Введите строку:');
readln(s);
for i:=2 to length(s) do begin
if s[i]=' '
then begin
x:=i+1;
while (s[x]<>' ') and (x<length(s)) do begin
delete(s,x,1);
end;
delete(s,x,1);
break;
end;
end;
writeln(s);
end.
--------------------------
Пример 1:
мама мыла
мама
Пример 2:
Мама мыла раму
Мама раму
---------------------------
PS: считается, что строка не начинается с пробела и не может быть два пробела подряд
Новые вопросы
Математика,
2 года назад
Математика,
2 года назад
Химия,
8 лет назад
Алгебра,
8 лет назад
Алгебра,
9 лет назад