Информатика, вопрос задал ekaterina99 , 2 года назад

КТО РЕШИТ , ТОМУ 70 БАЛЛОВ!! составить программу нахождения суммы чисел , кратных 3 в массиве М [1:12] (числа вводятся с клавиатуры)

Ответы на вопрос

Ответил антагонист
1
Program enot_peredelani;
Var a: array[1..100] of integer;
c,d:integer;
begin
d:=0;
writeln('введите элемент массива');
for c:= 1 to 12 do
begin
readln(a[c]);
if a[c] mod 3 = 0 then 
d:=a[c]+d;
end;
writeln('сумма чисел кратных 3 ==> ',d);
end.

антагонист: всё работает как надо, я проерял
антагонист: проверял
антагонист: хотя можно чуток узменить
антагонист: Program enot;
Var a: array[1..100] of integer;
c,d:integer;
begin
d:=0;
for c:= 1 to 12 do begin
writeln('введите элемент массива');
readln(a[c]);
if a[c] mod 3 = 0 then d:=a[c]+d;
end;
writeln('сумма чисел кратных 3 ==> ',d);
end.
Аноним: Еще раз вынесете в комментарии текст программы - начнете копить баллы предупреждений
антагонист: без проблем
Ответил Аноним
1
const
  n=12;
var
  M:array[1..n] of integer;
  i,s:integer;
begin
  Writeln('Введите ',n,' элементов массива');
  s:=0;
  for i := 1 to n do
  begin Read(M[i]); if M[i] mod 3=0 then s:=s+M[i] end;
  Writeln('Сумма элементов, кратных трем, равна ',s)
end.

Тестовое решение:
Введите 12 элементов массива
32 18 40 52 8 14 28 35 18 21 11 41
Сумма элементов, кратных трем, равна 57

Новые вопросы