Кто-нибудь помогите написать прогу в С++
1.Написать программу:
Пользователь вводит с клавиатуры число х
Программа должна посчитать у по формуле и вывести значение у на экран
у=cos(x)
2.Написать программу:
Пользователь вводит с клавиатуры число х
Программа должна посчитать у по формуле и вывести значение у на экран

Программа не должна аварийно останавливаться при отрицательных значениях под корнем квадратным
3.Написать программу, вычисляющую произведение целых чисел в диапазоне от 10 до 2001
4.Написать программу:
Пользователь вводит с клавиатуры целое отрицательное число х
Программа должна посчитать сумму целых чисел от 0 до х
Ответы на вопрос
Ответ:
Объяснение:
#include <iostream>
#include <math.h>
using namespace std;
int main()
{
double x;
cout<<"Input number x in radian ";
cin>>x;
cout<<"\n cos(x) = "<<cos(x);
return 0;
}
///====
#include <iostream>
#include <math.h>
using namespace std;
int main()
{
double x;
cout<<"Input number x in radian ";
cin>>x;
double y1 = cos(x);
if (y1 < 0) cout<<"cos(x)<0, корень вычислиь нельзя";
else
{
cout<<"\n корень(cos(x)) = "<<sqrt(y1);
}
return 0;
}
//-------------------
#include <iostream>
using namespace std;
int main()
{
double summ = 0;
for (int i = 10;i<2002;i++)
{
summ += i;
}
cout<<"Сумма равна "<<summ;
return 0;
}
//----------------------
#include <iostream>
using namespace std;
int main()
{
int x;
cout<<"Введети отрицательное целое число x ";
cin>>x;
int summ;
for (int i = 0;i<=abs(x);i++)
{
summ += (-i);
}
cout<<"Сумма равна "<<summ;
return 0;
}