Кто может разобрать ?? 70 Баллов)
Program n1;
var i,n,sum: integer;
begin
readln(n);
sum:=0;
for i:=1 to n do sum:=sum+2*i;
writeln(sum);
end.
Написать программу, которая вычисляет сумму первых n целых положительных четных чисел. Количество суммируемых чисел должно вводится во время работы программы.
Ответы на вопрос
Program n1;
//Название программы
var i,n,sum: integer;
//Объявление переменных
begin
//Начало
readln(n);
//Ввод n (количество чисел) и и переход на следущую строку
sum:=0;
//Присваивание переменной sum знаяения 0 (изначально сумма равна 0)
for i:=1 to n do sum:=sum+2*i;
//В цикле от 1 до n к переменной
//sum прибавляем 2*i, т.е. 1*2+2*2+3*2+..n*2=2+4+6+..+2n;
writeln(sum);
//Ввод sum (cумма первых n целых положительных четных чисел)
//и и переход на следущую строку
end.
//Конец
Program n1;// программа на паскале n1
var i,n,sum: integer;// объявление целых переменных i,n и sum
begin //начало программы
readln(n); //ввод n
sum:=0;/ /присвоение переменной sum нач. значения 0
for i:=1 to n do sum:=sum+2*i;// цикл для вычисления суммы
writeln(sum);// печать суммы
end. //конец программы