Информатика, вопрос задал Uchenik78912 , 7 лет назад

Кто может помочь написать простую программку python?


Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое двузначных чисел или сообщает, что таких чисел нет. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести среднее арифметическое двузначных чисел или вывести NO, если таких чисел в последовательности нет.

Ответы на вопрос

Ответил Fedy16
0

Ответ:

numbers = []

number = input()

while number != '0':

   if len(number) == 2:

       numbers.append(int(number))

   number = input()

if len(numbers) == 0: print('NO')

else: print(sum(numbers) // len(numbers))

Новые вопросы