Информатика, вопрос задал zalyatdinova06 , 2 года назад

Количество пятерок
На вход программе подается последовательность целых чисел от 1 до 5, характеризующее оценку ученика, каждое число на отдельной строке. Концом последовательности является любое отрицательное число, либо число большее 5. Напишите программу, которая выводит количество пятерок.
ПОМОГИТЕ ПРОШУ

Ответы на вопрос

Ответил maxum000
3

Python:

mark = int(input())

count = 0

if mark == 5:

       count += 1

while (mark<=5 and mark>0):

   mark = int(input())

   if mark == 5:

       count += 1

print(count)

Ввод/Вывод:

1                                                                                                                                

1                                                                                                                                

5                                                                                                                                

5                                                                                                                                

5                                                                                                                                

5                                                                                                                                

5                                                                                                                                

-1                                                                                                                              

5    

Новые вопросы