Информатика, вопрос задал kotelrody , 7 лет назад

Код на Python (БЕЗ МАССИВА)

Искал решение около 20-и минут, все не правильно, либо с массивами

Сумма произведений соседних чисел
По заданной последовательности a1, a2, …, an чисел вычислите сумму a1∗a2+a2∗a3+⋯+an−1∗an.

Входные данные

Первая строка входных данных содержит число n≥2. В следующих n строках вводится по одному числу. В i+1 строке содержится значение i-того элемента последовательности. Все числа во входном файле натуральные, не превосходящие 100.

Выходные данные

Выведите ответ на задачу.

Примеры
Ввод 4 2 3 1 5 | Вывод 14


mirageKZ: "Все числа во входном файле натуральные" - откуда в условии взялся файл? Мы числа вводим с клавиатуры или считываем из файла? Вы определитесь.
kotelrody: Взял с сайта, там опечатка, "входной файл" это input

Ответы на вопрос

Ответил mirageKZ
4

Ответ:

Python

n=int(input('Введите n : '))

s=0

b=0

for i in range(n):

   a=int(input('a['+str(i)+']='))

   if i!=0:

         s+=a*b

   b=a

print(s)


mirageKZ: Если не сложно, поставь ЛО
kotelrody: Я не знаю как, но поставил 5 звезд и "Спасибо"
mirageKZ: Корона где то , это и есть ЛО
Новые вопросы