Код на C#. Напишите программу для нахождения максимального элемента в каждом столбце и минимального в каждой строке квадратной матрицы.
Ответы на вопрос
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace AutoIT // это название проекта. Ты можешь назвать
// по-другому
{
internal class Program
{
static void Main(string[] args)
{
int N;
N = int.Parse(Console.ReadLine());
int[,] vs = new int[N, N];
for(int i = 0; i < N; i++)
{
for (int j = 0; j < N; j++)
{
vs[i, j] = int.Parse(Console.ReadLine());
}
}
for(int i = 0; i < N; i++)
{
Console.WriteLine();
for (int j = 0; j < N; j++)
{
Console.Write(String.Format("{0,3}", vs[i, j]));
}
Console.WriteLine();
}
Console.WriteLine("Минимальные элементы в каждой строчке");
for (int i = 0; i < N; i++)
{
int min = 10000;
for (int j = 0; j < N; j++)
{
if(min > vs[i,j]) min = vs[i,j];
}
Console.WriteLine(min);
}
Console.WriteLine("Максимальные элементы в каждом столбце");
for (int j = 0; j < N; j++)
{
int max = -10000;
for (int i = 0; i < N; i++)
{
if (max < vs[i, j]) max = vs[i, j];
}
Console.WriteLine(max);
}
Console.ReadLine();
}
}
}