как составить программу?
составьте программу,определяющею,является ли последняя цифра введенного целого числа нечетным числом?
Ответы на вопрос
Ответил Mishka28
0
Pascal:
var n:longint;
begin
write ('N = ');
readln (n);
if ((n mod 10) mod 2 = 1) then writeln ('YES') else writeln ('NO');
readln;
end.
C++:
#include <iostream>
using namespace std;
int main()
{
long n;
cout <<"N = ";
cin >> n;
if ((n%10)%2==1)
cout <<"YES" <<endl;
else cout <<"NO" <<endl;
return 0;
}
var n:longint;
begin
write ('N = ');
readln (n);
if ((n mod 10) mod 2 = 1) then writeln ('YES') else writeln ('NO');
readln;
end.
C++:
#include <iostream>
using namespace std;
int main()
{
long n;
cout <<"N = ";
cin >> n;
if ((n%10)%2==1)
cout <<"YES" <<endl;
else cout <<"NO" <<endl;
return 0;
}
Новые вопросы