Как решить задачу в Pascal ABC: Задана последовательность целых чисел напишите программу которая определяет длину этой последовательности???
Ответы на вопрос
Ответил selsve2
0
Преобразуешь к строковому представлению через процедуру str(i,s), где i-последовательность, а s строка. И потом короч
for n:=1 to length(s) do //length считывает строку до последнего элемента
b:=b+1;
writeln('Кол-во чисел ',b);
end.
for n:=1 to length(s) do //length считывает строку до последнего элемента
b:=b+1;
writeln('Кол-во чисел ',b);
end.
Ответил selsve2
0
какой класс и как давно изучаете?
Ответил НатсуДрагнил
0
ты неправельно неписал...
Ответил НатсуДрагнил
0
var
n, k: longint;
begin
assign(input,'input.txt');
reset(input);
assign(output,'output.txt');
rewrite(output);
n := 1;
k := -1;
while n <> 0 do begin
readln(n);
k := k + 1;
end;
writeln(k);
end.
n, k: longint;
begin
assign(input,'input.txt');
reset(input);
assign(output,'output.txt');
rewrite(output);
n := 1;
k := -1;
while n <> 0 do begin
readln(n);
k := k + 1;
end;
writeln(k);
end.
Ответил НатсуДрагнил
0
вот правельно
Ответил selsve2
0
мне никто не сказал, что используется текстовый файл...
Новые вопросы
Русский язык,
2 года назад
ОБЖ,
2 года назад
Математика,
9 лет назад
Математика,
9 лет назад
Математика,
9 лет назад