Информатика, вопрос задал anna20013 , 10 лет назад

Как написать программу которая напишет все целые числа от 1 до 50 которые кратны 9 и посчитает их произведение и сумму

Ответы на вопрос

Ответил emblerik
0

Берем цикл от 1 до 50, идем и проверяем все числа на кратность 9, если кратны, то пишем число и добавляем к сумме (и умножаем произведение).

 

var

  sum, mul, i : integer;

begin

   sum := 0; mul := 1;

  for i := 1 to 50 do

    if i mod 9 = 0 then

    begin

      write (i, '  ');

      sum := sum + i;

      mul := mul * i;

    end;

  writeln;

  writeln ('sum = ', sum);

  writeln ('mul = ', mul);

end.

Новые вопросы