Информатика, вопрос задал petruhov07 , 1 год назад

Как написать программу к Python? С клавиатуры вводится два целых числа из 10 цифр, где первые 2 цифры - это день, следующие 2 цифры - это месяц, а последние 4 - это год.

Пример даты: 14052001
День: 14
Месяц: 5
Год: 2001

Первое число - дата проведения "Соревнования по прыжкам с табуретки", второе число "Кулинарный фестиваль бутерброда".

Выведите на эран название мероприятия, которое случилось раньше. Если даты мероприятий совпадают, то выведите на экран фразу "В один день".

Ответы на вопрос

Ответил Viacheslavkrilov
1

a, b, c = input(), input(), 2

aY, aM, aD = int(a[0:2]), int(a[2:4]), int(a[4::1])

bY, bM, bD = int(b[0:2]), int(b[2:4]), int(b[4::1])

aW, bW, abW = "Соревнования по прыжкам с табуретки", "Кулинарный фестиваль бутерброда", "В один день"

A = [aY, aM, aD]

B = [bY, bM, bD]

W = [aW, bW, abW]

for i in range(0, 2):

 if A[i] < B[i]:

   c = 0

   break

 elif B[i] < A[i]:

   c = 1

   break

print(W[c])

проверил, вроде работает

Новые вопросы