Как написать программу для вычисления наибольшего общего делителя?
На языку С.
Ответы на вопрос
Ответил asvalias
0
#include <stdio.h>
int main() {
unsigned long a, b;
scanf("%lu%lu", &a, &b);
while(a && b) {
if(a>b)
a %= b;
if(b>a)
b %= a;
}
printf("%lu", a | b);
}
Решение по алгоритму Евклида.
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Математика,
7 лет назад
Алгебра,
7 лет назад
Химия,
9 лет назад
Математика,
9 лет назад