Информатика, вопрос задал youssrywa , 2 года назад

используя язык питона Написать программу для подсчета среднего значения всех введенных пользователем чисел. Индикатором окончания ввода будет служить ноль. При этом программа должна выдавать соответствующее сообщение об ошибке, если первым же введенным пользователем значением будет ноль.


trueberry17: Какой язык программирования?
trueberry17: Нужно ли добавлять except ValueError?
trueberry17: Ну типо, избежание ошибок, если пользователь не ввёл число, или ввёл, но букву ?

Ответы на вопрос

Ответил trueberry17
1

Ответ: Если правильно поняла, нужно было так..

Python Code

import numpy as np

numbs = list()

print('Введите числа для поиска среднего арифметического значения.')

print('Введите 0, чтобы прекратить ввод чисел.')

while True:

   user_input = ui = input(': ')

   if ui == '0' and len(numbs) < 2:

       print('Ошибка! Вы не ввели числа.')

   elif ui == '0' and len(numbs) > 1:

       print(f'Введенные числа:\n{numbs}\nСр. значение чисел:\n{np.mean(numbs)}')

       break

   else:

       numbs.append(int(ui))

Приложения:

trueberry17: Если что-то непонятно, или не устраивает ответ - пиши
Новые вопросы