Информатика, вопрос задал twarm , 10 лет назад

Используя циклы решить задачи в паскале:

1) Ввести число и вывести все его делители

2) Составить программу, планирования закупки товаров в магазине на сумму, не превышающую заданной величины.

Ответы на вопрос

Ответил ali07
0

ЗАдача 1.

program xxx;

var i, n : integer

begin

  writeln ('введите число N=');

  readln (n);

  writeln ('Делители числа:');

  for i:= 1 to n do

    if n mod i = 0 then writeln (i);

  readln

end.

Новые вопросы