Информатика, вопрос задал Aliyahqy10 , 1 год назад

Используя цикл с параметром, написать программу, которая вычисляет сумму заданного с клавиатуры числа элементов ряда 1/2+1/4-1/6+1/8....

СРОЧНО ПОМОГИТЕ ПОЖАЛУЙСТА

Ответы на вопрос

Ответил fedrfedr
2

Ответ:

program Calc;

var

 i, n, m: Integer;

 s: Double;

begin

 Write ('Количество членов ряда = ');

 ReadLn (m);

 s := 0.5;

 n := 1;

 for i := 2 to m do begin

   s := s + n / (i * 2);

   n := -n;

 end;

 WriteLn ('S = ', s :20 :20);

 ReadLn;

end.

Новые вопросы
Математика, 1 год назад