Информатика тема "Паскаль"
Напишите программу, которая считывает с клавиатуры переменные данные a, b, c и вычисляет следующие выражения:
Screenshot_1.jpg
При любых значениях переменных программа выполняется корректно? С чем это связано?
Приложения:

Ответы на вопрос
Ответил petyaGavrikov
0
var a,b,c,y1,y2,y3:real;
begin
readln(a,b,c);
y1:=sqrt(2*a-3)/(b-1)+sqrt(c*c+a*c+a*a);
writeln('y1 = ',y1:7:3);
y2:=sqrt(2+sqrt(2+sqrt(b+sqrt(abs(c-a)))));
writeln('y2 = ',y2:7:3);
y3:=1/(1+1/(a+(1-b)/(1-c)));
writeln('y3 = ',y3:7:3);
end.
Пример:
2 5 3
y1 = 4.609
y2 = 2.027
y3 = 0.800
Программа не будет вычислять значения, если:
1) какое-либо подкоренное выражение будет < 0;
2) знаменатель какой-либо дроби будет = 0.
(например, при a=1; b=-1; c=1)
begin
readln(a,b,c);
y1:=sqrt(2*a-3)/(b-1)+sqrt(c*c+a*c+a*a);
writeln('y1 = ',y1:7:3);
y2:=sqrt(2+sqrt(2+sqrt(b+sqrt(abs(c-a)))));
writeln('y2 = ',y2:7:3);
y3:=1/(1+1/(a+(1-b)/(1-c)));
writeln('y3 = ',y3:7:3);
end.
Пример:
2 5 3
y1 = 4.609
y2 = 2.027
y3 = 0.800
Программа не будет вычислять значения, если:
1) какое-либо подкоренное выражение будет < 0;
2) знаменатель какой-либо дроби будет = 0.
(например, при a=1; b=-1; c=1)
Ответил zcwe16
0
Вы гений!спасибо Вам!
Ответил petyaGavrikov
0
Пожалуйста.
Ответил Eminem79
0
Можно для тупого пж
Ответил Eminem79
0
еще раз
Новые вопросы
Математика,
2 года назад
Математика,
2 года назад
Математика,
8 лет назад
Математика,
9 лет назад
Математика,
9 лет назад