Информатика, вопрос задал bo0000 , 2 года назад

Информатика, срочно!
10 вопрос
Нужно написать программу

Приложения:

lexa23072003: тебе на чем надо? на паскале?
bo0000: Да

Ответы на вопрос

Ответил lexa23072003
1

var n,s,p,max:integer;

begin

p:=1;

max:=0;

s:=0;

write('Введите число ');

readln(n);

While(n>0) do begin

s:=s+(n mod 10);

p:=p*(n mod 10);

if ((n mod 10) > max) Then max:= n mod 10;

n:=n div 10;

end;

write('сумма всех цифр ',s,' произведение цифр ',p,' маскимальное число ',max);

end.

Новые вопросы