Информатика, вопрос задал vika0569 , 1 год назад

Информатика.

Составить программу нахождения суммы целых положительных чисел, кратных 7 и не превосходящих заданное число n.​

Ответы на вопрос

Ответил ForeignAgent
2

Ответ:

Объяснение:

program SevenEleven;

var

n, i, Result : integer;

begin

Result:=0;

i:=0;

repeat

 writeln ('Input N: ');

 readln (n);

until n>0;

while i <= n do begin

  Result:=Result+i;

  i:=i+7;

end;

Writeln('Result = ', Result);

end.

Новые вопросы