Информатика: решение задачи на языке Паскаль. Текст задачи: даны три натуральных числа. Напишите программу, определяющую существует ли треугольник с такими длинами сторон. Если такой треугольник существует, то определите его тип (равносторонний, равнобедренный, разносторонний)
Ответы на вопрос
Ответил Аноним
0
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!
begin
var (a,b,c):=ReadInteger3('a b c =');
if (a+b>c) and (a+c>b) and (b+c>a) then
if (a=b) or (a=c) or (b=c) then
if (a=b) and (b=c) then Writeln('Треугольник равносторонний')
else Writeln('Треугольник равнобедренный')
else Writeln('Треугольник разносторонний')
else Writeln('Треугольник не существует')
end.
Внимание! Если программа не работает, обновите версию!
begin
var (a,b,c):=ReadInteger3('a b c =');
if (a+b>c) and (a+c>b) and (b+c>a) then
if (a=b) or (a=c) or (b=c) then
if (a=b) and (b=c) then Writeln('Треугольник равносторонний')
else Writeln('Треугольник равнобедренный')
else Writeln('Треугольник разносторонний')
else Writeln('Треугольник не существует')
end.
Ответил vlados400125
0
неверно, так как если треугольника не существует - твоя программа ошибается!
Ответил Аноним
0
Спасибо, забыл поставить проверку, сейчас поправлю.
Ответил Аноним
0
Поправил
Ответил vlados400125
0
var
i, a, b, c: integer;
function check_is(a, b, c: integer):
boolean;
begin
if a >= b + c then check_is := false
else if b >= a + c then
check_is := false else
if c >= a + b then check_is := false else
check_is := true;
end;
procedure check_how(a, b, c: integer);begin
if ((a = b) and (b = c) and (a = c)) then writeln('равносторонний') else
if ((a = b) or (b = c) or (a = c)) then writeln('равнобедренный') else writeln('разносторонний');
end;
begin
writeln('Введите стороны треугольника');
read(a, b, c);
if check_is(a, b, c) then check_how(a, b, c) else writeln('Нет такого треугольника!');
end.
i, a, b, c: integer;
function check_is(a, b, c: integer):
boolean;
begin
if a >= b + c then check_is := false
else if b >= a + c then
check_is := false else
if c >= a + b then check_is := false else
check_is := true;
end;
procedure check_how(a, b, c: integer);begin
if ((a = b) and (b = c) and (a = c)) then writeln('равносторонний') else
if ((a = b) or (b = c) or (a = c)) then writeln('равнобедренный') else writeln('разносторонний');
end;
begin
writeln('Введите стороны треугольника');
read(a, b, c);
if check_is(a, b, c) then check_how(a, b, c) else writeln('Нет такого треугольника!');
end.
Ответил vlados400125
0
скопировалось плохо, но работает. зато правильно
Ответил Аноним
0
Если текст не отформатируете сейчас, то потом либо модераторы предложат отформатировать, либо просто удалят ответ.
Новые вопросы