Информатика, вопрос задал Аноним , 2 года назад

Информатика, работа в ПАСКАЛЕ
составить программу для проверки, является ли сумма цифр двухзначного четной.
(например, 24 и 6 эта сумма четная. А у 25 и 7 она ничетная)

Ответы на вопрос

Ответил JordanCarter
1
  • Program Brainly;
  • Var a, b: integer;
  • Begin
  • Writeln('Введите число а: ');
  • Readln(a);
  • Writeln('Введите число b: ');
  • Readln(b);
  • if (((a + b) mod 2=0)) then writeln('Сумма цифр – чётная')
  • else writeln('Сумма цифр – нечётная');
  • end.
Приложения:

pinguinbird: Мм...мне кажется в задании немного про другое. Дано двузначное число. Например, 24. Надо проверить, чётная ли сумма цифр данного числа, то есть 2 + 4. А вы просто сумму двух чисел проверяете. В общем, мне кажется ответ неверный, просто потому что неправильно понята суть задачи.
pinguinbird: и кстати, у вас синтаксис неверный, так что программа не заработает.
Аноним: У меня все работает
pinguinbird: ну хорошо, только неправильное решение это, т.к. задача про другое :)
pinguinbird: и вообще символ ";" перед "end" не ставится :)
pinguinbird: но это ладно, некоторые компиляторы на это забивают.
pinguinbird: Вот такой должен быть код:

program HomeWork;
var a:integer;
begin
write('Введите двузначное число: '); readln(a);
if ((a div 10) + (a mod 10)) mod 2 = 0 then write('Сумма цифр чётная!')
else write('Сумма цифр нечётная!')
end.
JordanCarter: Будь что-то не то, автор задания мне сказал это, и я исправил бы. А так, ваша замечания мне до лампочки.
pinguinbird: оу, что тут сказать, пусть так
Новые вопросы