информатика работа в паскале
Дан треугольник со сторонами a b c, составить программу для нахождения периметра, площади и высот Ha Hb Hc треугольника
restIess:
если формулы нахождения высот подгонишь, то напишу программу)
Ответы на вопрос
Ответил evilforestart
0
var
a,b,c,P,p2,S,Ha,Hb,Hc:real;
begin
writeln('Введите значение стророны a');
readln(a);
writeln('Введите значение стророны b');
readln(b);
writeln('Введите значение стророны c');
readln(c);
P:=a+b+c;
p2:=P/2;
S:=sqrt(p2*(p2-a)*(p2-b)*(p2-c));
Ha:= 2*sqrt(p2*(p2-a)*(p2-b)*(p2-c))/a;
Hb:= 2*sqrt(p2*(p2-a)*(p2-b)*(p2-c))/b;
Hc:= 2*sqrt(p2*(p2-a)*(p2-b)*(p2-c))/c;
writeln('Периметр треугольника P = '+P);
writeln('площадь треугольника S = '+S);
writeln('высота треугольника Ha = '+Ha);
writeln('высота треугольника Hb = '+Hb);
writeln('высота треугольника Hc = '+Hc);
end.
Новые вопросы