Информатика, вопрос задал maks2007060615 , 2 года назад

Информатика.
ПОМОГИТЕ ПЖ! Составить программу которая определяет если число кратно трём, то это увеличиваем на 1, иначе уменьшаем на 2. ​


s1veme: Какой язык?

Ответы на вопрос

Ответил s1veme
0

Ответ:

var x:integer;

begin

   readln(x);

   

   if (x mod 3=0) then

       x := x + 1

   else

       x := x - 2;

       

   writeln(x);

end.

Объяснение:

Если я верно понял задачу, то решение выше.

Вводим число, если оно кратно 3 - прибавляем 1, если нет - вычту 2.

После вывожу результат.

Новые вопросы