Информатика, вопрос задал wvm75074 , 2 года назад

Информатика. помогите плз составить программу в ПАСКАЛЕ:
Найти сумму чисел от 1 до n двумя способами

Ответы на вопрос

Ответил HиKиTа
1

Способ №1: с помощью цикла for

program s1;

var N,S,i:integer;

BEGIN

writeln('Нахождение суммы чисел от 1 до n');

write('Введите число: ');

readln(N);

for i:=1 to n do

S:=S+i;

writeln('Сумма чисел равна: ', s);

END.

Способ №2: с помощью формулы суммы арифметической последовательности S_{n}=\frac{a_{1}+a_{n} }{2} *n

program s2;

var N,i:integer;

S:real;

BEGIN

writeln('Нахождение суммы чисел от 1 до n');

write('Введите число: ');

readln(N);

S:= ( (1 + n)/2 )*N;

writeln('Сумма чисел равна: ', s);

END.

Новые вопросы