Информатика (Pascal): Составить программу для решения следующей задачи: Среди всех положительных трёхзначных чисел найти и выписать на экран те,у которых сумма крайних цифр совпадает с утроенной средней цифрой.
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1439 от 09.05.2017
// Внимание! Если программа не работает, обновите версию!
begin
for var i:=1 to 9 do
for var j:=0 to 9 do
for var k:=0 to 9 do
if i+k=3*j then Write(i,j,k,' ');
Writeln
end.
Результат
112 125 138 211 224 237 310 323 336 349 422 435 448 521 534 547 620 633 646 659 732 745 758 831 844 857 930 943 956 969
// Внимание! Если программа не работает, обновите версию!
begin
for var i:=1 to 9 do
for var j:=0 to 9 do
for var k:=0 to 9 do
if i+k=3*j then Write(i,j,k,' ');
Writeln
end.
Результат
112 125 138 211 224 237 310 323 336 349 422 435 448 521 534 547 620 633 646 659 732 745 758 831 844 857 930 943 956 969
Новые вопросы