Информатика, вопрос задал MBmagic , 8 лет назад

ИНФОРМАТИКА 9 КЛАСС ДАЮ 50 БАЛЛОВ
написать программу в ABCпаскаль
которая вычислит сумму цифр пятизначного числа и определит находится ли эта сумма в диапазоне от 20 до 25 включительно(<= или >=)

Ответы на вопрос

Ответил igor9997799
0
var
  i, c: int64;
  s: string;
 begin
  readln(s);
  if(s.Length = 5) then
begin
    for i := 1 to 5 do
      c := c + strtoint(s[i]);
    writeln(c);
    if(c >= 20) and (c <= 25) then write('Находится')
    else write('Не находится');
  end;
end.
Ответил igor9997799
0
И почему ты отметил мое решение как нарушение если ты не знаешь что неправильно? Разберись сначала с заданием.
Новые вопросы