Информатика 50 баллов. Составьте программу нахождения произведения всех натуральных чисел из диапазона от А до В, включая А и В, кратных 2 и 3 одновременно(А и В вводятся с клавиатуры).
Ответы на вопрос
Ответил gfhjkmgfhjkm20
0
Ответ:
program z1;
var i,a,b,p:integer;
begin
write('a = ');
readln (a);
write('b = ');
readln (b);
p:=1;
for i:=a to b do
if (i mod 2 = 0) and (i mod 3 =0) then p:=p*i;
if p <> 1 then writeln ('Произведение чисел, кратных 2 и 3 одновременно, равно ',p)
end.
Объяснение:
Если таких чисел нет, то программа ничего не выводит.
Если промежуток очень большой, то лучше изменить тип p (например, на real), чтобы не было переполнения.
Новые вопросы
Английский язык,
2 года назад
Русский язык,
2 года назад
Русский язык,
2 года назад
Математика,
2 года назад