ИНФ.9КЛ.ЦИКЛ
Задание:
Составить программу вывода таблицы перевода температур из градусов по шкале Цельсия в градусы по шкале Фаренгейта(F) для значений от 15 градусов C до 25 градусов с шагом 1 по Цельсию (F=1,8*C+32).
Образ:
по Цельсию по Фаренгейту
15 59
16 68
.... ......
23 77
Ответы на вопрос
Ответил DNHelper
0
Программа написана на PascalABC.NET v. 3.3
program task;
var
F: string;
begin
writeln('/-------------|-------------');
writeln('| По Цельсию |По Фаренгейту|');
writeln('|-------------|-------------|');
for var i := 15 to 25 do begin
str(1.8 * i + 32, F);
writeln('| ', i, ' | ', F, '|':(8 - length(F)))
end;
writeln('-------------|-------------/');
end.
program task;
var
F: string;
begin
writeln('/-------------|-------------');
writeln('| По Цельсию |По Фаренгейту|');
writeln('|-------------|-------------|');
for var i := 15 to 25 do begin
str(1.8 * i + 32, F);
writeln('| ', i, ' | ', F, '|':(8 - length(F)))
end;
writeln('-------------|-------------/');
end.
Новые вопросы