Хепланите плиз
Написать программу на языке Pascal
Вариант 4
Приложения:

Ответы на вопрос
Ответил Segrif
0
var pi,inR: real;
function a(RR:real; n:integer):real;
begin
a := 2*RR*sin(pi/n)
end;
function r(RR:real; n:integer):real;
begin
r := RR * cos(pi/n)
end;
function S(RR:real; n:integer):real;
begin
S := a(RR,n) * n * r(RR,n) / 2
end;
begin
pi := 4 * arctan(1);
read(inR);
writeln(S(inR,10));
writeln(S(inR,50));
writeln(S(inR,100))
end.
function a(RR:real; n:integer):real;
begin
a := 2*RR*sin(pi/n)
end;
function r(RR:real; n:integer):real;
begin
r := RR * cos(pi/n)
end;
function S(RR:real; n:integer):real;
begin
S := a(RR,n) * n * r(RR,n) / 2
end;
begin
pi := 4 * arctan(1);
read(inR);
writeln(S(inR,10));
writeln(S(inR,50));
writeln(S(inR,100))
end.
Новые вопросы
Русский язык,
2 года назад
Математика,
9 лет назад
Алгебра,
9 лет назад
Алгебра,
9 лет назад
Геометрия,
9 лет назад