Информатика, вопрос задал 298189 , 2 года назад

Help
Pascal ABC
Напишите программу, которая для произвольного четырехзначного натурального числа N
Вычисляет:
А) произведение первой и последней цифры числа N;
Б) если число N нечетное - выводит новое число М, образованное из числа N путем
обмена местами двух последних цифр между собой (пример – было 1234, стало 1243).​


298189: :(
Леганда555: под произвольным числом имеется ввиду случайное число или то, которое вводится пользователем?
298189: Пользователем
298189: четырехзначное
Леганда555: это да
Леганда555: а его пользователь вводит?
Леганда555: или программа сама должна его случайным образом сгенерировать?
298189: только пользователь
Леганда555: и ещё вопрос по примеру
Леганда555: в условии сказано, что если число N нечётное, то поменять две последние цифры местами, а в примере введено число 1234 и при этом оно изменяется

Ответы на вопрос

Ответил Леганда555
1

var

       n, m: Integer;

       

begin

       Read (n);

       

       WriteLn ('Произведение первой и последней цифры числа ', n, ': ', (n div 1000) * (n mod 10));

       WriteLn;

       

       if Odd (n) then begin

               m := (n div 1000) * 1000 + (n div 100 mod 10) * 100 + (n mod 10) * 10 + (n mod 100 div 10);

               

               WriteLn ('Число ', n, ' нечётное, поэтому новое число равно: ', m);

       end;

end.        

Новые вопросы