Информатика, вопрос задал svetlanaivanova2 , 8 лет назад

! ! ! ! ! HELP ! ! ! ! ! 34 балла
Составить программу,которая подсчитывает количество сочетаний 'темп' в произвольном тексте,введённом с клавиатуры.

Ответы на вопрос

Ответил petyaGavrikov
0
var s,t:string; k,p:integer;
begin
writeln('Введите строку:');
readln(s);
t:=s;
k:=0;
p:=pos('темп',t);
while p>0 do
 begin
 k:=k+1;
 delete(t,p,4);
 p:=pos('темп',t);
 end;
writeln('k = ',k);
end.

Пример:
Введите строку:
темп медленный, темп средний, темп быстрый
k = 3
Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1338 от 16.11.2016
begin
  var s:=ReadlnString('->');
  var k:=RegEx.Matches(s,'Темп',RegexOptions.IgnoreCase).Count;
  Writeln(k);
end.

Пример:
-> В темпе вальса телевизор "Темп" измерял свою температуру
3

Новые вопросы