Информатика, вопрос задал 2016dreamer2016 , 8 лет назад

Хеееееееелп
Написать программу, которая определит принадлежит ли заштрихованной области (рисунок) точка с координатами X,Y

Приложения:

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (x,y):=ReadReal2('Введите через пробел координты x и y точки:');
  if (x>0) and (x*x+y*y<25) and (x*x+y*y>9) then Writeln('Принадлежит')
  else Writeln('Не принадлежит')
end.
Приложения:
Ответил AlexanderMikhailov
0
Вы просто поняли свою ошибку и теперь решили включить режим оправдания
Ответил AlexanderMikhailov
0
"круга радиуса 5"?
Ответил AlexanderMikhailov
0
О чём вы говорите?
Ответил AlexanderMikhailov
0
В общем, я долб. Если вы имеете в виду, что границы заштрихованной области не принадлежат это области, то да, вы правы.
Ответил Аноним
0
А если принадлежат, неравенства просто нужно сделать нестрогими.
Новые вопросы