>> Составить программу на Паскале. <<
Сформировать двухмерный массив A[1..10,1..10] случайными значениями в диапазоне [0..20]. Создать одномерный массив B[1..10], значения элементов которого равны сумме элементов строк двухмерного массива. Массив B вывести на экран.
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1555 от 21.10.2017
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('*** Исходный массив A ***');
var a:=MatrRandom(10,10,0,20);
a.Println(3); Writeln(3*a.ColCount*'-');
var b:=a.Rows.Select(row->row.Sum).ToArray;
Writeln('*** Массив B ***'); b.Println
end.
Пример
*** Исходный массив A ***
9 15 8 17 18 10 17 15 19 18
18 0 10 5 20 2 16 3 20 17
1 11 3 8 4 19 14 10 15 13
4 2 14 11 4 13 10 2 5 3
8 5 16 19 1 9 14 16 18 10
2 14 13 19 19 18 11 20 12 20
16 7 0 6 13 16 7 20 1 7
12 14 18 16 9 16 16 5 7 16
4 19 12 5 10 11 9 16 12 6
1 10 10 6 7 0 5 10 5 5
------------------------------
*** Массив B ***
146 111 98 68 116 148 93 129 104 59
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('*** Исходный массив A ***');
var a:=MatrRandom(10,10,0,20);
a.Println(3); Writeln(3*a.ColCount*'-');
var b:=a.Rows.Select(row->row.Sum).ToArray;
Writeln('*** Массив B ***'); b.Println
end.
Пример
*** Исходный массив A ***
9 15 8 17 18 10 17 15 19 18
18 0 10 5 20 2 16 3 20 17
1 11 3 8 4 19 14 10 15 13
4 2 14 11 4 13 10 2 5 3
8 5 16 19 1 9 14 16 18 10
2 14 13 19 19 18 11 20 12 20
16 7 0 6 13 16 7 20 1 7
12 14 18 16 9 16 16 5 7 16
4 19 12 5 10 11 9 16 12 6
1 10 10 6 7 0 5 10 5 5
------------------------------
*** Массив B ***
146 111 98 68 116 148 93 129 104 59
Ответил Аноним
0
Я же, к примеру, не в курсе уровня знаний программирования у Вашего преподавателя.
Ответил Keymad
0
Ну окей, а это через циклы и условия сложно реализовать?
Ответил Аноним
0
Да нет тут никаких сложностей кроме муторной писанины.
Ответил Аноним
0
PascalABC.NET как раз и создавался, чтобы этой дурной писаниной не заниматься, а Вы хотите меня снова в нее окунуть? )))
Ответил Аноним
0
Напоминает армейский анекдот, когда на вопрос, зачем лопатами рыть канаву до вечера, когда рядом стоит экскаватор, старшина отвечал: "А мне не канава нужна, а что бы вы замаялись!"
Новые вопросы
Химия,
2 года назад
Алгебра,
2 года назад
Информатика,
8 лет назад
Химия,
8 лет назад
Математика,
9 лет назад