Информатика, вопрос задал dnd1 , 9 лет назад

генератором случайных чисел (от 0 до 100) задан массив из 20 целых чисел.составьте программу, с помощью которой напечатайте на одной строчке исходный массив, а на следующей строке - сумму квадратов элементов с начетными индексами.

Ответы на вопрос

Ответил Pro100Cool
0
const  n = 20;
var  a :array [1..n] of integer;  i, sum :integer;
begin
  randomize;  for i:= 1 to n do    a[i]:= random(100);  for i:= 1 to n do    write(a[i],' ');  writeln;      sum:= 0;  for i:= 1 to n do    if i mod 2 = 1 then      sum:= sum + sqr(a[i]);  writeln(sum);
end.
Новые вопросы