Информатика, вопрос задал nozik1301 , 2 года назад

Free pascal. Написать программу детектирования слова-полиндрома

Ответы на вопрос

Ответил НиколайСПБ
0
Написал я Вам программу, у себя проверил - работает, думаю и у вас должно.

Program Palindrome_or_not;

var
s: string;
i,f: byte;
begin
write('Введите слово: ');
readln(s);
f := 0;
for i := 1 to length(s) div 2 do
if s[i] <> s[length(s)-i+1] then begin
writeln('Введённое слово не является палиндромом');
f := 1;
break
end;
if f = 0 then
write('Введённое слово является палиндромом');
end.

Надеюсь помог, удачи :)
Новые вопросы