Информатика, вопрос задал slv2008 , 10 лет назад

Это программирование, паскаль, нужно написать программу 










Дан одномерный массив A, состоящий из N элементов, N – заданное натуральное
число. Если элементы массива составляют строго монотонную последовательность, то
все положительные элементы массива заменить единицей, иначе оставить массив без
изменения. 





Ответы на вопрос

Ответил Аноним
0
a:array[1..30000] of integer;
n, i, k, z:integer;
begin
readln(n);
for i:=1 to n do
readln(a[i]);
for i:=1 to n do
if (a[i]<a[i+1]) then k:=k+1;
for i:=1 to n do
if (a[i]>a[i+1]) then z:=z+1;
if (k=n) or (z=n) then
for i:=1 to n do
if a[i]>0 then a[i]:=1;
for i:=1 to n do
writeln(a[i]);
readln;
end.
Ответил Аноним
0
если не будет работать попробуйте (k=n) or (z=n) then begin и end после a[i]:=1;
Новые вопросы