Есть тут знатоки С++? Помогите плизз,
1.Написать программу с++, что находит в двухмерном массиве размерностью 4*3, сумму элементов 3 строки
2. Написать программу с++ для нахождения суммы всех нечётных элементов одномерного массива
Помогите пожалуйста )))
gbsnat:
чел, ты других слов не знаешь?)
Ответы на вопрос
Ответил gbsnat
0
#include <iostream>
#include <vector>
using namespace std;
void solve_1() {
const int N = 4, M = 3;
int sum = 0;
vector<vector<int>> a(N, vector<int>(M));
for (int i = 0; i < N; i++) {
for (int j = 0; j < M; j++) {
cin >> a[i][j];
sum += a[i][j] * (i == 2);
}
}
cout << sum;
}
void solve_2() {
int N, sum = 0;
cin >> N;
vector<int> a(N);
for (auto &i : a) {
cin >> i;
sum += i * (i % 2);
}
cout << sum;
}
signed main(){
solve_1();
solve_2();
}
Новые вопросы
Английский язык,
2 года назад
Химия,
2 года назад
Биология,
2 года назад
Математика,
8 лет назад
Литература,
8 лет назад