Информатика, вопрос задал Veraa2 , 9 лет назад

Есть ли в массиве элементы, равные числу, введённому пользователем?

Паскаль. Помогите составить программу и оформить ответ!

Ответы на вопрос

Ответил Galina2013
0
var a: array[1..10] of real;
x: real;
a, i: integer;
begin
a:=0;
for i:=1 to 10 do begin
readln(a[i]);
if a[i] = x then 
a:=a+1;
end;
if a>0 then
writeln('Таких элементов ', a)
else
writeln('Такого элемента нет');
end.


Ответил Аноним
0
var 
a: array[1..100] of integer; 
i, j, c: integer;
begin 
Writeln('Массив '); 
for i := 1 to 100 do  begin   
a[i] := random(201) - 100;   
write(a[i], ' '); 
end; 
Writeln; 
write('Введите число (от -100 до 100) '); 
Readln(j); 
for i := 1 to 100 do    
if a[i] = j then begin c := c + 1; write(i, ' '); end; 
Writeln;   
if c>1 then write('В массиве число введённое вами есть в массиве и даже несколько (', c, '). Их индексы представлены выше') else  if c = 1 then write('Число, которое вы ввели есть в массиве. Его индекс представлен выше') else write('Такого числа в массиве нет');  
end.
Новые вопросы