Информатика, вопрос задал asdasd48 , 1 год назад

Двумерные массивы.
Задача:
В прямоугольной таблице подсчитать произведение элементов в каждой строке
Составить программу на языке программирования Pascal


iolandavalerypad353: массив какого типа? как инициализировать массив, какими значениями и откуда?
iolandavalerypad353: размерность массива?

Ответы на вопрос

Ответил fedrfedr
0

Ответ:

program ArrMul;

var

 a: array [1..10, 1..10] of Real;

 i, j: Integer;

 p: Real;

begin

 Randomize;

 for i := 1 to 10 do begin

   WriteLn;

   for j := 1 to 10 do begin

     a [i, j] := Random (10) + 1;

     Write (a [i, j] :6 :2);

   end;

 end;

 WriteLn;

 for i := 1 to 10 do begin

   p := 1;

   for j := 1 to 10 do begin

     p := p * a [i, j];

   end;

   WriteLn ('Строка ', i :2, p :20 :2);

 end;

 ReadLn;

end.

Объяснение:

Новые вопросы