Информатика, вопрос задал Колючая , 10 лет назад

Двумерные массивы.

Сам.работа Вар.2 С-14


1.Составьте программу вычисления суммы отрицательных элементов матрицы A(N,N)

2.Составьте программу вычисления произведения положительных элементов матрицы B(N,N)

3.Cоставьте программу вычисления суммы элементов третьего столбца матрицы С(N,N)



Решите пожалуйста(

Ответы на вопрос

Ответил archery
0

var a,b,c:array [1..100,1..100] of integer;

as,bs,cs,i,j:integer;

Begin

  sb:=1;

  for i := 1 to n do

     for j:= 1 to n do

     begin

       if a[i,j]<0 then sa:=sa+a[i,j];

       if b[i,j]>0 then sb:=sb*b[i,j];

       if j=3 then sc:=sc+c[i,j];

     end;

   writeln(sa,sb,sc);

End.

Новые вопросы