Информатика, вопрос задал Ggawp228 , 1 год назад

Дописать програму

Составить программу, которая бросать случайные числа из интервала от 10 до 50 пока не выпадет

заданное с клавиатуры число А (10<=A<=50). Указать количество «бросков» до совпадения.


Дописать програму

var

x, count, y:integer;

begin

writeln('Задумайие и введите число X (10<=x<=50)');

readln(x);

y:=

count:=

здесь пропущена строка

begin

y:=random(41)+10;

count:=

writeln('Бросок №',count,': y=',y);

end;

writeln;

writeln('Количество бросков до совпадения ', count)

end

Ответы на вопрос

Ответил LRSM
1

Ответ:

var

   x, count, y:integer;

begin

   writeln('Задумайие и введите число X (10<=x<=50)');

   readln(x);

   y:=0;

   count:=0;

   while x<>y do

   begin

       y:=random(41)+10;

       count:=count+1;

       writeln('Бросок №',count,': y=',y);

   end;

   writeln;

   writeln('Количество бросков до совпадения ', count)

end.


Аноним: чувак
LRSM: С этим помочь не могу, ибо не доводилось сталкиваться с таким родом задач, а разбираться неохота, просто not useful
Новые вопросы