Информатика, вопрос задал quendelin , 9 лет назад

Добрый вечер.
Пожалуйста, помогите написать программу (на Pascal) для решения квадратного уравнения.

Ответы на вопрос

Ответил danabel2000
0
var a,b,c,d,x1,x2:real;
begin
read(a,b,c);
d:=sqr(b)-4*a*c;
if(d>0)then begin
x1:=(-b+sqrt(d))/(2*a);
x2:=(-b-sqrt(d))/(2*a);
writeln('x1=',x1:3:5,' x2=',x2:3:5);
end else if(d=0)then begin x1:=-b/(2*a); writeln(x1:5);end
else writeln('Нет корней. Дискриминант меньше 0');
end.
Новые вопросы